存档

2013年11月 的存档

maven依赖版本冲突解决的误区

2013年11月27日 1 条评论

忘记是哪位大仙的说法,记忆中一直是maven依赖树中存在同一jar的多版本时,会自动依赖最新版本。

今天查找项目依赖时,发现在二级依赖中同时存在两个版本,maven引入的却是老版本。

翻了一下官方文档,只说是依赖于最近的版本。实测发现,同级中存在多个版本时,先依赖哪个版本就用哪个版本。

最靠谱的方法,就是直接依赖最新版本,也就是最近的依赖,会覆盖掉子级的低版本依赖。

更多内容…

分类: 工作 标签: ,